summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-23 22:57:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-23 22:57:16 +0100
commitdb0e9fe42c419c8c8010dbad6080ed66028c03ec (patch)
tree514a0d8fe5465db9a950ac20579e5d3e37bc385b /gnu/packages/mail.scm
parent43190ac64c5181841d68beade4d19e792f4f38a2 (diff)
parent82a2bd3a4ee09c04b51b948f1e952402d6a26f88 (diff)
downloadguix-db0e9fe42c419c8c8010dbad6080ed66028c03ec.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 67afea68fb..64f679e662 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2748,7 +2748,13 @@ operators and scripters.")
              (commit "abeb2c25935ef8c75f1e5deef0f81276754dc975")))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0rqgbw08a5lj41dkp82aq480lqkc4bnxagna7wpqffi821n8gkwz"))))
+        (base32 "0rqgbw08a5lj41dkp82aq480lqkc4bnxagna7wpqffi821n8gkwz"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Remove pre-built binaries scattered across the source repository.
+           (for-each delete-file (find-files "." "\\.(dll|exe)"))
+           #t))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags (list "CC=gcc")