summary refs log tree commit diff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-06 13:46:47 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-06 13:50:00 +0200
commit08005133eca561c9d090b6f535fa70b3cfef558a (patch)
tree26e57f86c953e9c87f81c9372a43de4733e38b9c /gnu/packages/make-bootstrap.scm
parent93bf42361ca3d88fd0c95bbb61dcf1fa9c508159 (diff)
downloadguix-08005133eca561c9d090b6f535fa70b3cfef558a.tar.gz
gnu: glibc-static: Fix static NSS support.
Support for static NSS broke in glibc 2.33, meaning that 'getpw' &
co. would always fail.  This patch backports the upstream fix to
reinstate it.

Reported by Marius Bakke.

* gnu/packages/patches/glibc-static-nss.patch: New file.
* gnu/packages/make-bootstrap.scm (glibc-for-bootstrap): Use it.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 12e59e9f83..2d7a97488d 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -30,7 +30,7 @@
   #:use-module ((guix licenses) #:select (gpl3+))
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system gnu)
-  #:use-module ((gnu packages) #:select (search-patch))
+  #:use-module ((gnu packages) #:select (search-patch search-patches))
   #:use-module (gnu packages base)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages bash)
@@ -73,8 +73,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
     (package
       (inherit base)
       (source (origin (inherit (package-source base))
-                      (patches (cons (search-patch "glibc-bootstrap-system.patch")
-                                     (origin-patches (package-source base))))))
+                      (patches (append (search-patches
+                                        "glibc-bootstrap-system.patch"
+                                        "glibc-static-nss.patch")
+                                   (origin-patches (package-source base))))))
       (arguments
        (substitute-keyword-arguments (package-arguments base)
          ((#:configure-flags flags)