summary refs log tree commit diff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-14 19:44:38 -0400
committerMark H Weaver <mhw@netris.org>2015-07-14 19:44:38 -0400
commitc09e6a5f5e2a77beff89d68069f3037c1b6310e5 (patch)
tree16268a85a9168156b838ed6071eb46a875133532 /gnu/packages/make-bootstrap.scm
parent2e9511dfbdb5ddd78c2f205c4ca7fc23738d79f8 (diff)
downloadguix-c09e6a5f5e2a77beff89d68069f3037c1b6310e5.tar.gz
gnu: Build tarballs deterministically.
* gnu/packages/make-bootstrap.scm (tarball-package)[arguments]: Build tarball
  deterministically.
* gnu/packages/admin.scm (isc-dhcp)[arguments]: In 'post-configure' phase,
  create bind.tar.gz deterministically.
* gnu/packages/video.scm (avidemux)[arguments]: In 'repack-ffmpeg' phase,
  create ffmpeg-1.2.1.tar.bz2 deterministically.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index e140582a4a..07e8b5160b 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -629,7 +629,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                                               ,(or (%current-target-system)
                                                    (%current-system))
                                               ".tar.xz")
-                               "."))))))))))
+                               "."
+                               ;; avoid non-determinism in the archive
+                               "--mtime=@0" "--owner=root:0" "--group=root:0"))))))))))
 
 (define %bootstrap-binaries-tarball
   ;; A tarball with the statically-linked bootstrap binaries.