summary refs log tree commit diff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-05 23:42:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-05 23:42:26 +0200
commit3359a70834f80f36ce8ef673f0f8adc1cc66d0d5 (patch)
treecf9c95a903b8785d9d7dc5689d207795d69d738e /gnu/packages/make-bootstrap.scm
parent44e3e431cdc5c6fa619dc691747042f235e9af8a (diff)
downloadguix-3359a70834f80f36ce8ef673f0f8adc1cc66d0d5.tar.gz
gnu: make-bootstrap: Inherit tar arguments in %static-inputs.
* gnu/packages/make-bootstrap.scm (%static-inputs)[tar]: Use
SUBSTITUTE-KEYWORD-ARGUMENTS so #:make-flags are inherited.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index a57491aeb4..475749bbf6 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -190,15 +190,17 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                             '()))))
 	(tar (package (inherit tar)
 	       (arguments
-		'(#:phases (modify-phases %standard-phases
-			     (add-before 'build 'set-shell-file-name
-			       (lambda _
-				 ;; Do not use "/bin/sh" to run programs; see
-                                 ;; <http://lists.gnu.org/archive/html/guix-devel/2016-09/msg02272.html>.
-				 (substitute* "src/system.c"
-				   (("/bin/sh") "sh")
-				   (("execv ") "execvp "))
-				 #t)))))))
+                (substitute-keyword-arguments (package-arguments tar)
+                  ((#:phases phases)
+                   `(modify-phases ,phases
+                      (replace 'set-shell-file-name
+                        (lambda _
+                          ;; Do not use "/bin/sh" to run programs; see
+                          ;; <http://lists.gnu.org/archive/html/guix-devel/2016-09/msg02272.html>.
+                          (substitute* "src/system.c"
+                            (("/bin/sh") "sh")
+                            (("execv ") "execvp "))
+                          #t))))))))
         ;; We don't want to retain a reference to /gnu/store in the bootstrap
         ;; versions of egrep/fgrep, so we remove the custom phase added since
         ;; grep@2.25. The effect is 'egrep' and 'fgrep' look for 'grep' in