summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-30 15:05:13 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:54:04 +0200
commite445ae9ae13dc33f3770324c58cb91cd89185846 (patch)
treef0c6798385435804adf8b3f9e05f05747e5e5390 /gnu/packages/man.scm
parent56db7a6613637b0696cb6cd40f7e70bed43627c1 (diff)
downloadguix-e445ae9ae13dc33f3770324c58cb91cd89185846.tar.gz
gnu: Add ronn.
* gnu/packages/man.scm (ronn): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 1335c24fa0..6db7b0a37f 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -30,6 +30,7 @@
   #:use-module (guix download)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system ruby)
   #:use-module (gnu packages dbm)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gawk)
@@ -39,6 +40,30 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages linux))
 
+(define-public ronn
+  (package
+    (name "ronn")
+    (version "0.7.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/rtomayko/ronn.git")
+         (commit version)))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "0fkniz7j1jp8v3i05m6hks3nsh6rzvjfi0ichpi7h4gwk5byxb94"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f))                   ; Library hpricot not available
+    (synopsis "Manual authoring tool")
+    (description "Ronn builds manuals.  It converts simple, human readable
+textfiles to roff for terminal display, and also to HTML for the web.")
+    (home-page "https://rtomayko.github.io/ronn/")
+    (license expat)))
+
 (define-public libpipeline
   (package
     (name "libpipeline")