summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-22 11:29:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-22 15:43:22 -0400
commit2f7ab8e373b100c955d21fdb71145b76ac16cf94 (patch)
tree81aeefadbc187ed48629b3899df92290fbcd9ca7 /gnu/packages/man.scm
parent8e3d4f05dfc852f4584c94aebb04bc74138c933d (diff)
downloadguix-2f7ab8e373b100c955d21fdb71145b76ac16cf94.tar.gz
gnu: man-db: Simplify 'patch-test-shebangs' phase.
* gnu/packages/man.scm (man-db)[phases]{patch-test-shebangs}: Do not filter
nonexistent directories from find-files.
[modules]: Delete field.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 14aaa36ea1..1c1d82758b 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -146,8 +146,7 @@ a flexible and convenient way.")
                                  (substitute* file
                                    (("#! /bin/sh")
                                     (string-append "#!" (which "sh")))))
-                               (remove file-is-directory?
-                                       (find-files "src/tests" ".*"))))))
+                               (find-files "src/tests")))))
                (add-after 'unpack 'patch-absolute-paths
                  (lambda* (#:key inputs #:allow-other-keys)
                    (substitute* "src/man.c"
@@ -194,10 +193,7 @@ a flexible and convenient way.")
                    '("nroff" "eqn" "neqn" "tbl" "refer" "pic")))
            ;; At run time we should refer to GROFF-MINIMAL, not GROFF (the latter
            ;; pulls in Perl.)
-           #:disallowed-references (list groff)
-           #:modules '((guix build gnu-build-system)
-                       (guix build utils)
-                       (srfi srfi-1))))
+           #:disallowed-references (list groff)))
     (native-inputs
      (list pkg-config flex
            ;; Groff is needed at build time for troff, grops, soelim, etc.