summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-17 19:56:59 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-17 21:22:20 +0100
commit841e5fb4ddff7f29c06cf9faea65cfe5626fde20 (patch)
tree28fa250e70da40ee249b7703b2b665359bb89c69 /gnu/packages/man.scm
parentd7b4ccefa9452033dc8f6875ef40b108591ad5b4 (diff)
downloadguix-841e5fb4ddff7f29c06cf9faea65cfe5626fde20.tar.gz
gnu: scdoc: Don't use unstable tarball.
The autogenerated tarball was modified upstream.

* gnu/packages/man.scm (scdoc)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 21a9c73892..d6ace365fc 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -293,13 +293,13 @@ automatically.")
    (version "1.10.1")
    (source
     (origin
-     (method url-fetch)
-     (uri (string-append "https://git.sr.ht/%7Esircmpwn/scdoc/archive/" version
-                         ".tar.gz"))
-     (file-name (string-append name "-" version ".tar.gz"))
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://git.sr.ht/~sircmpwn/scdoc")
+           (commit version)))
+     (file-name (git-file-name name version))
      (sha256
-      (base32
-       "13x7g1r56bshvfmlvapvz35ywnbgsh337kywb5kcv8nc6b3j3q40"))))
+      (base32 "1xmh6fnp378xmiycslg4migs1vx7yly4i1cf2vbbnwim9c9g0aw7"))))
    (build-system gnu-build-system)
    (arguments
     `(#:make-flags