summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-17 12:27:18 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-01-17 12:29:40 +0100
commit073f5f20578f36022748a7692f369214ecf7363a (patch)
treeff64c94acd724b0c4eabb011bf887c366b1ec212 /gnu/packages/man.scm
parent3d540c48e7521713bea910fed6245c0468836cf2 (diff)
downloadguix-073f5f20578f36022748a7692f369214ecf7363a.tar.gz
Revert "Revert "gnu: man-db: Embed absolute reference to 'preconv'.""
This reverts commit ccb15b343e35d76a5c7c693f4c00d3f5b5a4cc39.

Now that we've fixed the segfault with groff's preconv (see
73b2ce87956b0d9168dcfa234128b91e0e41a4c7), it's safe to re-apply this fix.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 68d6c16178..fbc5ca27ef 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -82,11 +83,19 @@ a flexible and convenient way.")
                          (remove file-is-directory?
                                  (find-files "src/tests" ".*")))
                #t)))
-         (add-after 'unpack 'patch-iconv-path
+         (add-after 'unpack 'patch-absolute-paths
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "src/man.c"
                (("\"iconv\"")
                 (string-append "\"" (which "iconv") "\"")))
+             ;; Embed an absolute reference to "preconv", otherwise it
+             ;; falls back to searching in PATH and ultimately fails
+             ;; to render unicode data (see <https://bugs.gnu.org/30785>).
+             (substitute* "lib/encodings.c"
+               (("groff_preconv = NULL")
+                (string-append "groff_preconv = \""
+                               (assoc-ref inputs "groff-minimal")
+                               "/bin/preconv\"")))
              #t)))
        #:configure-flags
        (let ((groff (assoc-ref %build-inputs "groff"))