summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-10-29 00:46:33 +0900
committerMarius Bakke <mbakke@fastmail.com>2019-10-28 23:04:48 +0100
commit84836379cd63f427dedda619d97aee0b352b86cd (patch)
tree04322874a3f2e33c4d702e25545aa5e49b4ce3a5 /gnu/packages/man.scm
parentb2b8a39c4130b6a7bb1c9a96078cd14f0f086860 (diff)
downloadguix-84836379cd63f427dedda619d97aee0b352b86cd.tar.gz
gnu: scdoc: Set PREFIX instead of patching Makefile.
* gnu/packages/man.scm (scdoc)[arguments]: Set PREFIX instead of patching
Makefile with output path.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 86efe64e52..e7e14c54ae 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -251,15 +251,11 @@ automatically.")
        "00zc3rzj97gscby31djlqyczvqpyhrl66i44czwzmmn7rc5j03m1"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:make-flags '("CC=gcc")
+    `(#:make-flags
+      (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
       #:phases
       (modify-phases %standard-phases
-        (delete 'configure)
-        (add-before 'install 'hardcode-paths
-          (lambda* (#:key outputs #:allow-other-keys)
-            (substitute* "Makefile"
-                         (("/usr/local") (assoc-ref outputs "out")))
-            #t)))))
+        (delete 'configure))))
    (home-page "https://git.sr.ht/~sircmpwn/scdoc")
    (synopsis "Simple man page generator")
    (description "scdoc is a simple man page generator written for POSIX systems