summary refs log tree commit diff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-04 19:49:17 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-04 20:18:10 +0200
commit4a5ae4ebf7f1705577480d758649358b69e961b6 (patch)
treed398c5de55ce70e3e9475cfd118035462971e4f1 /gnu/packages/man.scm
parent5ef1b17578cc247df10257d982a4cd670a74a94a (diff)
downloadguix-4a5ae4ebf7f1705577480d758649358b69e961b6.tar.gz
gnu: man-db: Make some inputs native.
* gnu/packages/man.scm (man-db)[inputs]: Move flex from here...
[native-inputs]: ...to here.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 6d7d5e2339..7463b1dbd8 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -137,10 +138,10 @@ a flexible and convenient way.")
                   (srfi srfi-1))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("flex" ,flex)
        ("groff" ,groff)))   ;needed at build time (troff, grops, soelim, etc.)
     (inputs
-     `(("flex" ,flex)
-       ("gdbm" ,gdbm)
+     `(("gdbm" ,gdbm)
        ("groff-minimal" ,groff-minimal)
        ("less" ,less)
        ("libpipeline" ,libpipeline)