summary refs log tree commit diff
path: root/gnu/packages/markdown.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-06-08 17:14:06 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-06-10 00:11:36 +0200
commite5eede3fb37e5f50542f138f86ee752696442580 (patch)
tree3bdb36f468f26e1d181b12ab4f1536fd9f934376 /gnu/packages/markdown.scm
parent0866dd46a97082a963acc631ecae02820c718079 (diff)
downloadguix-e5eede3fb37e5f50542f138f86ee752696442580.tar.gz
gnu: Rename (gnu packages markdown) to (gnu packages markup).
* gnu/packages/markdown.scm: Rename this ...
* gnu/packages/markup.scm: ... to this.
* gnu-system.am (GNU_SYSTEM_MODULES): Change markdown.scm to markup.scm.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/markdown.scm')
-rw-r--r--gnu/packages/markdown.scm132
1 files changed, 0 insertions, 132 deletions
diff --git a/gnu/packages/markdown.scm b/gnu/packages/markdown.scm
deleted file mode 100644
index 4a020198e4..0000000000
--- a/gnu/packages/markdown.scm
+++ /dev/null
@@ -1,132 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
-;;; Copyright © 2015 David Thompson <davet@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages markdown)
-  #:use-module (guix licenses)
-  #:use-module (guix download)
-  #:use-module (guix packages)
-  #:use-module (guix build-system gnu)
-  #:use-module (guix build-system trivial)
-  #:use-module (guix build-system cmake)
-  #:use-module (gnu packages perl)
-  #:use-module (gnu packages python)
-  #:use-module (gnu packages web)
-  #:use-module (gnu packages zip))
-
-(define-public hoedown
-  (package
-    (name "hoedown")
-    (version "3.0.7")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/hoedown/hoedown/archive/"
-                                 version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
-             (sha256
-              (base32
-               "0859dc2xjasd6kgkshi8mb20kbyw5sql1ln0hw3bfaf33qdh5dh1"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure)) ; no configure script
-       #:test-target "test"))
-    (native-inputs
-     `(("python" ,python-2)
-       ("tidy" ,tidy)))
-    (synopsis "Markdown processing library")
-    (description "Hoedown is a standards compliant, fast, secure markdown
-processing library written in C.")
-    (home-page "https://github.com/hoedown/hoedown")
-    (license expat)))
-
-(define-public markdown
-  (package
-    (name "markdown")
-    (version "1.0.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "http://daringfireball.net/projects/downloads/"
-             (string-capitalize name) "_" version ".zip"))
-       (sha256
-        (base32 "0dq1pj91pvlwkv0jwcgdfpv6gvnxzrk3s8mnh7imamcclnvfj835"))))
-    (build-system trivial-build-system)
-    (arguments
-     '(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-         (let ((source (assoc-ref %build-inputs "source"))
-               (out    (assoc-ref %outputs "out"))
-               (perlbd (string-append (assoc-ref %build-inputs "perl") "/bin"))
-               (unzip  (string-append (assoc-ref %build-inputs "unzip")
-                                      "/bin/unzip")))
-           (mkdir-p out)
-           (with-directory-excursion out
-             (system* unzip source)
-             (mkdir "bin")
-             (mkdir-p "share/doc")
-             (rename-file "Markdown_1.0.1/Markdown.pl" "bin/markdown")
-             (rename-file "Markdown_1.0.1/Markdown Readme.text"
-                          "share/doc/README")
-             (patch-shebang "bin/markdown" (list perlbd))
-             (delete-file-recursively "Markdown_1.0.1"))))))
-    (native-inputs `(("unzip" ,unzip)))
-    (inputs `(("perl" ,perl)))
-    (home-page "http://daringfireball.net/projects/markdown")
-    (synopsis "Text-to-HTML conversion tool")
-    (description
-     "Markdown is a text-to-HTML conversion tool for web writers.  It allows
-you to write using an easy-to-read, easy-to-write plain text format, then
-convert it to structurally valid XHTML (or HTML).")
-    (license (non-copyleft "file://License.text"
-                           "See License.text in the distribution."))))
-
-(define-public cmark
-  (package
-    (name "cmark")
-    (version "0.27.1")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/jgm/cmark/archive/"
-                                 version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
-             (sha256
-              (base32
-               "1da62ispca9aal2a36gaj87175rv5013pl7x740vk32y6lclr6v6"))))
-    (build-system cmake-build-system)
-    (arguments
-     '(#:test-target "test"))
-    (native-inputs `(("python" ,python)))
-    (synopsis "CommonMark Markdown reference implementation")
-    (description "CommonMark is a strongly defined, highly compatible
-specification of Markdown.  cmark is the C reference implementation of
-CommonMark.  It provides @code{libcmark} shared library for parsing
-CommonMark to an abstract syntax tree (AST) and rendering the document
-as HTML, groff man, LaTeX, CommonMark, or an XML representation of the
-AST.  The package also provides the command-line program @command{cmark}
-for parsing and rendering CommonMark.")
-    (home-page "http://commonmark.org")
-    ;; cmark is distributed with a BSD-2 license, but some components are Expat
-    ;; licensed. The CommonMark specification is Creative Commons CC-BY-SA 4.0
-    ;; licensed. See 'COPYING' in the source distribution for more information.
-    (license (list bsd-2 expat cc-by-sa4.0))))