summary refs log tree commit diff
path: root/gnu/packages/markdown.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-07-19 10:41:34 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-07-20 09:16:58 -0400
commit7782d3a6ffd8d25371cc28834a4966ac302dd469 (patch)
tree22f2f157fdbe026d4820df41aed5883e9fb3d343 /gnu/packages/markdown.scm
parentb56724ec5ff996053e0ae3d7ca476fc34f67b097 (diff)
downloadguix-7782d3a6ffd8d25371cc28834a4966ac302dd469.tar.gz
gnu: Add hoedown.
* gnu/packages/markdown.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/markdown.scm')
-rw-r--r--gnu/packages/markdown.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/markdown.scm b/gnu/packages/markdown.scm
new file mode 100644
index 0000000000..58ca10277a
--- /dev/null
+++ b/gnu/packages/markdown.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages markdown)
+  #:use-module (guix licenses)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages web))
+
+(define-public hoedown
+  (package
+    (name "hoedown")
+    (version "3.0.3")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://github.com/hoedown/hoedown/archive/"
+                                 version ".tar.gz"))
+             (file-name (string-append name "-" version ".tar.gz"))
+             (sha256
+              (base32
+               "0mmmkfayqgh6k39kbi3pq68mg03x35aiygy3zypxzvwx9y8b53ky"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-before 'build 'fix-makefile
+                              (lambda* (#:key outputs #:allow-other-keys)
+                                (setenv "CC" "gcc")
+                                (substitute* '("Makefile")
+                                  (("/usr/local")
+                                   (assoc-ref outputs "out")))
+                                #t))
+                  (delete 'configure)) ; no configure script
+       #:test-target "test"))
+    (native-inputs
+     `(("python" ,python-2)
+       ("tidy" ,tidy)))
+    (synopsis "Markdown processing library")
+    (description "Hoedown is a standards compliant, fast, secure markdown
+processing library written in C.")
+    (home-page "https://github.com/hoedown/hoedown")
+    (license expat)))