summary refs log tree commit diff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 17:38:43 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:56:30 +0100
commit6d32d835aa40f655a42422765348cae9ba8eb334 (patch)
treeeccd7492720b2d4b47babf547439ffbe7db29420 /gnu/packages/markup.scm
parentc844489350570bae30442b6d264339029bee4f0f (diff)
downloadguix-6d32d835aa40f655a42422765348cae9ba8eb334.tar.gz
gnu: Add perl-commonmark.
* gnu/packages/markup.scm (perl-commonmark): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 791035deb3..35dd6d257b 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -46,6 +46,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -360,6 +361,33 @@ for parsing and rendering CommonMark.")
     ;; licensed. See 'COPYING' in the source distribution for more information.
     (license (list license:bsd-2 license:expat license:cc-by-sa4.0))))
 
+(define-public perl-commonmark
+  (package
+    (name "perl-commonmark")
+    (version "0.290000")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/N/NW/NWELLNHOF/CommonMark-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1pgaqa4f00i9r5z7l9xiya0q51ysq0nhpvgr0f3rza3cxz1v80d5"))))
+    (build-system perl-build-system)
+    (arguments
+     `(#:make-maker-flags
+       ;; MakeMaker ignores LIBRARY_PATH.
+       (list (format #f "LIBS=-L~a/lib -lcmark"
+                     (assoc-ref %build-inputs "cmark")))))
+    (inputs (list cmark perl-test-leaktrace perl-devel-checklib
+                  perl-module-build))
+    (home-page "https://metacpan.org/release/CommonMark")
+    (synopsis "Interface to the CommonMark C library")
+    (description
+     "This module is an XS wrapper around the official
+CommonMark C library libcmark.  It closely follows the original API.")
+    (license license:perl-license)))
+
 (define-public cmark-gfm
   (package
     (inherit cmark)