summary refs log tree commit diff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-30 13:56:26 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-06-10 00:12:13 +0200
commit83f0d3a5c8a1f551d7a92283d445fb605f9fb069 (patch)
treee3083c646c71971aa35eb6c7b34e50d95bc3edf7 /gnu/packages/markup.scm
parente5eede3fb37e5f50542f138f86ee752696442580 (diff)
downloadguix-83f0d3a5c8a1f551d7a92283d445fb605f9fb069.tar.gz
gnu: Add smu.
* gnu/packages/markup.scm (smu): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index de40de670d..cd883b23ec 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -130,3 +131,39 @@ for parsing and rendering CommonMark.")
     ;; licensed. The CommonMark specification is Creative Commons CC-BY-SA 4.0
     ;; licensed. See 'COPYING' in the source distribution for more information.
     (license (list bsd-2 expat cc-by-sa4.0))))
+
+(define-public smu
+  (package
+    (name "smu")
+    (version "1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/Gottox/smu/archive/v"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0iazl45rkz8ngsb5hpykl76w0ngvdvqqhym1qz5wykgmrzk293rp"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list "CC=gcc"
+                          (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:tests? #f ;No tests included
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (home-page "https://github.com/Gottox/smu")
+    (synopsis "Simple markup")
+    (description
+     "Smu is a very simple and minimal markup language.  It is
+designed for using in wiki-like environments.  Smu makes it very
+easy to write your documents on the fly and convert them into HTML.
+Smu is capable to parse very large documents.  As long as you avoid an huge
+amount of indents it scales just great.
+
+Smu was started as a rewrite of Markdown but became something more
+lightweight and consistent.  The biggest difference between Markdown
+and smu is that smu doesn't support reference style links.")
+    (license x11)))