summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-06 23:52:45 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-07 00:02:00 +0100
commit0d963875278d585eb86bc87127efa20a8d627595 (patch)
tree459adf7d6547f8e94d337796618acd1b8e4bb07d /gnu/packages/mate.scm
parentf88a0bb0db7a3a0e47c5377951b6de691c386775 (diff)
downloadguix-0d963875278d585eb86bc87127efa20a8d627595.tar.gz
gnu: mate-polkit-for-xfce: Break circular top-level references.
Fixes <https://issues.guix.gnu.org/61911>.
Reported by Maxime Devos <maximedevos@telenet.be>.

* gnu/packages/xfce.scm (mate-polkit-for-xfce): Move to...
* gnu/packages/mate.scm (mate-polkit-for-xfce): ... here.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index ce62366985..2f38946fe1 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1470,6 +1470,23 @@ MATE Desktop to monitor your system resources and usage.")
 used to bring up authentication dialogs.")
     (license license:lgpl2.1)))
 
+(define-public mate-polkit-for-xfce
+  (package/inherit mate-polkit
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'patch-desktop
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((common (string-append
+                             (assoc-ref outputs "out") "/etc/xdg/autostart/"
+                             "polkit-mate-authentication-agent-"))
+                    (old (string-append common "1.desktop"))
+                    (new (string-append common "for-xfce-1.desktop")))
+               (substitute* old (("MATE;") "XFCE;"))
+               ;; To avoid a conflict if both MATE and XFCE are installed.
+               (rename-file old new)))))))
+    (properties `((hidden? . #t)))))
+
 (define-public mate
   (package
     (name "mate")