summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-30 23:48:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-31 14:16:13 +0200
commitc000352c27f511dfb5569bef09f9b774d6100117 (patch)
treeca8f6b37cfd0506db1c4440ab1f2bf45fedb031a /gnu/packages/mate.scm
parent3b57a9cac8962068a3abad1aa09477e9a433460e (diff)
downloadguix-c000352c27f511dfb5569bef09f9b774d6100117.tar.gz
gnu: Replace all uses of atk by at-spi2-core.
* gnu/packages/animation.scm (gnash)
* gnu/packages/chromium.scm (ungoogled-chromium)
* gnu/packages/crates-gtk.scm (rust-atk-sys-0.14,
rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14)
* gnu/packages/gimp.scm (gimp)
* gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex):
* gnu/packages/graphviz.scm (xdot)
* gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm)
* gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc,
mate-utils, eom, pluma)
* gnu/packages/messaging.scm (dino)
* gnu/packages/qt.scm (qtwebengine-5)
* gnu/packages/rust-apps.scm (alfis)
* gnu/packages/vim.scm (vim-full)
* gnu/packages/vnc.scm (remmina)
* gnu/packages/web.scm (castor): Replace atk by at-spi2-core.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 2f38946fe1..4874aaf7f9 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -521,7 +521,7 @@ assorted menu related utility programs.")
            docbook-xml
            gobject-introspection))
     (inputs
-     (list atk
+     (list at-spi2-core
            dbus
            dbus-glib
            glib
@@ -732,7 +732,7 @@ infamous 'Wanda the Fish'.")
        ("xmllint" ,libxml2)
        ("zlib" ,zlib)))
     (inputs
-     `(("atk" ,atk)
+     `(("at-spi2-core" ,at-spi2-core)
        ("cairo" ,cairo)
        ("caja" ,caja)
        ("dconf" ,dconf)
@@ -921,7 +921,7 @@ icons on the MATE desktop.  It works on local and remote file systems.")
            xmodmap
            gobject-introspection))
     (inputs
-     `(("atk" ,atk)
+     `(("at-spi2-core" ,at-spi2-core)
        ("cairo" ,cairo)
        ("caja" ,caja)
        ("dconf" ,dconf)
@@ -1061,7 +1061,7 @@ sessions, panels, menus, file management, and preferences.")
     (native-inputs
      (list gettext-minimal intltool pkg-config yelp-tools))
     (inputs
-     (list atk
+     (list at-spi2-core
            glib
            gtk+
            libxml2
@@ -1228,7 +1228,7 @@ can be used as backgrounds in the MATE Desktop environment.")
            xorgproto
            yelp-tools))
     (inputs
-     (list atk
+     (list at-spi2-core
            cairo
            glib
            gtk+
@@ -1277,7 +1277,7 @@ can be used as backgrounds in the MATE Desktop environment.")
            pkg-config
            yelp-tools))
     (inputs
-     (list atk
+     (list at-spi2-core
            cairo
            dconf
            dbus
@@ -1382,7 +1382,7 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("pkg-config" ,pkg-config)
        ("yelp-tools" ,yelp-tools)))
     (inputs
-     (list atk
+     (list at-spi2-core
            cairo
            enchant-1.6
            glib