summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 21:39:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:20 -0500
commitfeab09f72abc6d6eec16a1b8d27c231c747c0e00 (patch)
treef041dbeda8bcc1c1115197643417fecad8613ba5 /gnu/packages/mate.scm
parent831c08d8f263f476e0293f8a5422e7314a159c91 (diff)
downloadguix-feab09f72abc6d6eec16a1b8d27c231c747c0e00.tar.gz
gnu: gtk: Replace gdk-pixbuf+svg by librsvg.
With the addition of a profile hook for computing the gdk-pixbuf loaders cache
file, there is no longer a need for gdk-pixbuf+svg, and librsvg can propagate
gdk-pixbuf without fear, so replace the former for the latter.

The replacement was automated with the following command:

   $ git grep -l ',gdk-pixbuf+svg)' \
     | xargs sed 's/(".*" ,gdk-pixbuf+svg)/("librsvg" ,librsvg)/' -i

* gnu/packages/gtk.scm (gdk-pixbuf+svg): Delete package.
(gtk+-2)[propagated-inputs]: Replace gdk-pixbuf+svg with librsvg.
(gtk+)[propagated-inputs]: Likewise.
* gnu/packages/gnome.scm (gdk-pixbuf+svg): Add deprecated package.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 08fd3562b3..41165e8de7 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -473,7 +473,7 @@ sound systems.")
        ("gobject-introspection" ,gobject-introspection)))
     (inputs
      `(("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("librsvg" ,librsvg)
        ("glib" ,glib)
        ("gtk+" ,gtk+)
        ("libx11" ,libx11)
@@ -983,7 +983,7 @@ icons on the MATE desktop.  It works on local and remote file systems.")
        ("polkit" ,polkit)
        ("startup-notification" ,startup-notification)))
     (propagated-inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf+svg) ; mate-slab.pc
+     `(("librsvg" ,librsvg) ; mate-slab.pc
        ("librsvg" ,librsvg))) ; mate-slab.pc
     (home-page "https://mate-desktop.org/")
     (synopsis "MATE Desktop configuration tool")
@@ -1219,7 +1219,7 @@ Re-decorates windows on un-maximise.
        ("dbus-glib" ,dbus-glib)
        ("glib" ,glib)
        ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("librsvg" ,librsvg)
        ("libcanberra" ,libcanberra)
        ("libglade" ,libglade)
        ("libmatekbd" ,libmatekbd)
@@ -1271,7 +1271,7 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("cairo" ,cairo)
        ("glib" ,glib)
        ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("librsvg" ,librsvg)
        ("libcanberra" ,libcanberra)
        ("libgtop" ,libgtop)
        ("libx11" ,libx11)
@@ -1324,7 +1324,7 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("exempi" ,exempi)
        ("glib" ,glib)
        ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("librsvg" ,librsvg)
        ("libcanberra" ,libcanberra)
        ("libx11" ,libx11)
        ("libxext" ,libxext)
@@ -1384,7 +1384,7 @@ can be used as backgrounds in the MATE Desktop environment.")
        ("file" ,file)
        ("glib" ,glib)
        ("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("librsvg" ,librsvg)
        ("json-glib" ,json-glib)
        ("libcanberra" ,libcanberra)
        ("libx11" ,libx11)