summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 03:59:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 04:24:23 +0200
commit3ae745fed327818039b644e0e7fcbebccdaf55e1 (patch)
tree88fe28c6806c7eea3b21da832e13186daeb07a35 /gnu/packages/mate.scm
parent5f6589281f633adf68473d82566945a71f93b728 (diff)
downloadguix-3ae745fed327818039b644e0e7fcbebccdaf55e1.tar.gz
gnu: libmateweather: Update to 1.24.1.
* gnu/packages/mate.scm (libmateweather): Update to 1.24.1.
[source]: Hard-code NAME.  Remove obsolete snippet.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index ab29c606aa..17c1abfb4f 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -256,24 +256,14 @@ desktop and the mate-about program.")
 (define-public libmateweather
   (package
     (name "libmateweather")
-    (version "1.24.0")
+    (version "1.24.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://mate/" (version-major+minor version) "/"
-                           name "-" version ".tar.xz"))
+                           "libmateweather-" version ".tar.xz"))
        (sha256
-        (base32
-         "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))
-       (modules '((guix build utils)))
-       ;; This is fixed by commit ea13e065 upstream. Remove this once 1.25.0
-       ;; is out.
-       (snippet
-        '(begin
-           (substitute* "data/Locations.xml.in"
-             (("Godthab")
-              "Nuuk"))
-           #t))))
+        (base32 "02d7c59pami1fzxg73mp6risa9hvsdpgs68f62wkg09nrppzsk4v"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags