summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:48:17 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:24 +0100
commit9f7d5768df8692b60d8ab2cecb9521dc11b5226b (patch)
tree74b50386e76963f591d8c9d63790967278c0f3cb /gnu/packages/mate.scm
parente91f9d4078a69412a62550fe3ae0e33a5c3ace38 (diff)
downloadguix-9f7d5768df8692b60d8ab2cecb9521dc11b5226b.tar.gz
gnu: Add mate-netbook.
* gnu/packages/mate.scm (mate-netbook): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index f5714acb64..26fea11277 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -62,6 +62,7 @@
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))
 
 (define-public mate-common
@@ -1110,6 +1111,48 @@ sessions, panels, menus, file management, and preferences.")
 can be used as backgrounds in the MATE Desktop environment.")
     (license license:gpl2+)))
 
+(define-public mate-netbook
+  (package
+    (name "mate-netbook")
+    (version "1.18.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pub.mate-desktop.org/releases/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0zj4x9qis8dw0irxzb4va1189k8bqbvymxq3h7phnjwvr1m983gf"))))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("libfakekey" ,libfakekey)
+       ("libwnck" ,libwnck)
+       ("libxtst" ,libxtst)
+       ("libx11" ,libx11)
+       ("mate-panel" ,mate-panel)
+       ("xproto" ,xproto)))
+    (home-page "https://mate-desktop.org/")
+    (synopsis "Tool for MATE on Netbooks")
+    (description
+     "Mate Netbook is a simple window management tool which:
+
+@enumerate
+@item Allows you to set basic rules for a window type, such as maximise|undecorate
+@item Allows exceptions to the rules, based on string matching for window name
+and window class.
+@item Allows 'reversing' of rules when the user manually changes something:
+Re-decorates windows on un-maximise.
+@end enumerate\n")
+    (license license:gpl3+)))
+
 (define-public mate
   (package
     (name "mate")