summary refs log tree commit diff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-08 21:54:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-08 22:18:07 +0200
commit9927943c307511b53d6c6e715c727f3747fff086 (patch)
treefc11d638224eb2003ca8a0a58ab37ac4b73e5000 /gnu/packages/mate.scm
parentb6c5ad85643e37ae18bf88cd9734894623508f39 (diff)
downloadguix-9927943c307511b53d6c6e715c727f3747fff086.tar.gz
gnu: mate-desktop: Update to 1.16.1.
* gnu/packages/mate.scm (mate-desktop): Update to 1.16.1.
[arguments]: Build with gtk+-3, enable mpaste.
[propagated-inputs]: Remove gtk+-2, move libxrandr,
startup-notification ...
[inputs]: ... to here.  Add gtk+-3, python-2.
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 68febad1d5..8885f73192 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -93,7 +93,7 @@ example Menta, TraditionalOk, GreenLaguna or BlackMate.")
 (define-public mate-desktop
   (package
     (name "mate-desktop")
-    (version "1.12.1")
+    (version "1.16.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://pub.mate-desktop.org/releases/"
@@ -101,8 +101,11 @@ example Menta, TraditionalOk, GreenLaguna or BlackMate.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "00ssrzm07xyrjra075jhir1f8iy382lla7923fhic29lap26mffr"))))
+                "1pzncfgrzp2mp9407ivk1113hkadpf110blr058h31jkwsk8syjq"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--with-gtk=3.0"
+                           "--enable-mpaste")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
@@ -111,11 +114,12 @@ example Menta, TraditionalOk, GreenLaguna or BlackMate.")
        ("yelp-tools" ,yelp-tools)))
        ;;("gtk-doc" ,gtk-doc))) ; add back in when gtk-doc builds
     (inputs
-     `(("libxrandr" ,libxrandr)))
-    (propagated-inputs
-     `(("dconf" ,dconf)
-       ("gtk+" ,gtk+-2)
+     `(("gtk+" ,gtk+)
+       ("libxrandr" ,libxrandr)
+       ("python2" ,python-2)
        ("startup-notification" ,startup-notification)))
+    (propagated-inputs
+     `(("dconf" ,dconf))) ; mate-desktop-2.0.pc
     (home-page "http://mate-desktop.org/")
     (synopsis "Library with common API for various MATE modules")
     (description