summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-06 01:36:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:36 -0500
commit661b25a2ed090bd16f212cefd45296221a141afc (patch)
tree037ef2541e246111a3bbd9fff9bce35e5db9afce /gnu/packages/maths.scm
parent9e497f44ba8104b6b4743e72cb041c8e15586a83 (diff)
downloadguix-661b25a2ed090bd16f212cefd45296221a141afc.tar.gz
gnu: openblas: Do not build static library.
* gnu/packages/maths.scm (openblas)[make-flags]: Add NO_STATIC=1.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 45c28106e7..42e59fae7a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4429,6 +4429,7 @@ parts of it.")
        (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
              "SHELL=bash"
              "MAKE_NB_JOBS=0"           ;use jobserver for submakes
+             "NO_STATIC=1"              ;avoid a 67 MiB static archive
 
              ;; This is the maximum number of threads OpenBLAS will ever use (that
              ;; is, if $OPENBLAS_NUM_THREADS is greater than that, then NUM_THREADS