summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-05-15 20:01:59 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-02 12:05:10 +0200
commit977bac689704eddfcb87dae8fec7e916ce711a03 (patch)
tree7ac3cefb163c3fa86520efba7fc5e805ff45214c /gnu/packages/maths.scm
parent4b443b41f46dc7575a72bbf1c1ab615c661177fa (diff)
downloadguix-977bac689704eddfcb87dae8fec7e916ce711a03.tar.gz
gnu: chuffed: Update to 0.13.2.
* gnu/packages/maths.scm (chuffed): Update to 0.13.2.

Change-Id: I77fc1ceb9caa42833689fba771010aeb38443e5e
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 84e1ed03ed..05634db0d8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -310,7 +310,7 @@ programmatic functions.")
 (define-public chuffed
   (package
     (name "chuffed")
-    (version "0.13.1")
+    (version "0.13.2")
     (source
      (origin
        (method git-fetch)
@@ -318,23 +318,21 @@ programmatic functions.")
              (url "https://github.com/chuffed/chuffed")
              (commit version)))
        (sha256
-        (base32 "1c28q166qh84q4i5wz77fqvw7kld3fmhd245sgdvyxcbjpi2wr0m"))))
+         (base32
+           "164brmwn71p9gb2441kh7b1gzmy2sg7bjv5z00wjs9nw41qc908g"))))
     (build-system cmake-build-system)
-    (synopsis "Lazy clause generation solver")
     (arguments
-     (list
-      #:tests? #f ;no 'test' target
-      #:phases #~(modify-phases %standard-phases
-                   (add-before 'build 'patch-msc
-                     (lambda _
-                       (let ((out #$output))
-                         (substitute* "chuffed.msc"
-                           ;; Replace fzn-chuffed and chuffed paths
-                           ;; before build.
-                           (("\\.\\./../..")
-                            out)
-                           (("\\.\\.")
-                            (string-append out "/share/minizinc")))))))))
+      (list #:tests? #f ;no 'test' target
+            #:phases
+            #~(modify-phases %standard-phases
+                (add-before 'build 'patch-msc
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let ((out (assoc-ref outputs "out")))
+                      (substitute* "chuffed.msc"
+                        (("\\.\\./../..") out)
+                        (("\\.\\.")
+                         (string-append out "/share/minizinc")))))))))
+    (synopsis "Lazy clause generation solver")
     (description
      "Chuffed is a state of the art lazy clause solver designed from the
 ground up with lazy clause generation in mind.  Lazy clause generation