summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-01 11:06:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-01 11:14:03 +0300
commit076688fa1e41a09f034a80e1a593bac43f1f1482 (patch)
treec8977801bed719b696616c6b34508614f1318c99 /gnu/packages/maths.scm
parent872e1434f1abed2ab75d011b0792d99575567efa (diff)
downloadguix-076688fa1e41a09f034a80e1a593bac43f1f1482.tar.gz
gnu: openblas: Update architectures we provide substitutes for.
* gnu/packages/maths.scm (openblas)[arguments]: Adjust the substitutable?
flag to only not provide substitutes when building for powerpc-linux.
Adjust the comment accordingly.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 663eb0cc10..662bd49895 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4573,15 +4573,8 @@ parts of it.")
     (arguments
      (list
       #:test-target "test"
-      ;; DYNAMIC_ARCH is only supported on x86.  When it is disabled and no
-      ;; TARGET is specified, OpenBLAS will tune itself to the build host, so
-      ;; we need to disable substitutions.
-      #:substitutable?
-      (let ((system (or (%current-target-system) (%current-system))))
-        (or (string-prefix? "x86_64" system)
-            (string-prefix? "i686" system)
-            (string-prefix? "mips" system)
-            (string-prefix? "aarch64" system)))
+      ;; No default baseline is supplied for powerpc-linux.
+      #:substitutable? (not (target-ppc32?))
       #:make-flags
       #~(list (string-append "PREFIX=" #$output)
               "SHELL=bash"