summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-11-30 21:26:01 -0600
committerEric Bavier <bavier@member.fsf.org>2016-12-01 23:50:09 -0600
commita4b0bfb1952a33b04cf2f2282633e7b342c16fb8 (patch)
tree6c0dfc095a29e8db23352a0028bd23906f0c9d10 /gnu/packages/maths.scm
parentb45baef15678b25c1ec910233db6045dbb15e264 (diff)
downloadguix-a4b0bfb1952a33b04cf2f2282633e7b342c16fb8.tar.gz
gnu: netcdf: Upgrade to 4.4.1.1.
* gnu/packages/maths.scm (netcdf, netcdf-parallel-openmpi): Upgrade to
4.4.1.1.
[source]: Adjust patch name, add netcdf-tst_h_par.patch
* gnu/packages/patches/netcdf-config.date.patch: Rename to...
* gnu/packages/patches/netcdf-date-time.patch: ...this.  Adjust for
latest source.
* gnu/packages/patches/netcdf-tst_h_par.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Adjust patches.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0ee573527a..fc98eae4f7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -714,7 +714,7 @@ HDF5 file is encoded according to the HDF File Format Specification.")
 (define-public netcdf
   (package
     (name "netcdf")
-    (version "4.4.0")
+    (version "4.4.1.1")
     (source
      (origin
        (method url-fetch)
@@ -722,8 +722,9 @@ HDF5 file is encoded according to the HDF File Format Specification.")
                            "netcdf-" version ".tar.gz"))
        (sha256
         (base32
-         "0y6gdcplarwqqnrav2xg1xd6ih732rzzbmdw78v3rl5b8mwcnh0d"))
-       (patches (list (search-patch "netcdf-config-date.patch")))))
+         "1blc7ik5yin7i0ls2kag0a9xjk12m0dzx6v1x88az3ras3scci2d"))
+       (patches (search-patches "netcdf-date-time.patch"
+                                "netcdf-tst_h_par.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("m4" ,m4)