summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2020-12-05 01:00:42 -0600
committerEric Bavier <bavier@member.fsf.org>2020-12-05 11:14:56 -0600
commit705af5403b3a8d7e942820bdff74195a1c3d9c89 (patch)
tree36eb33f20cfce7e15aad28c5451c35dfca5aada9 /gnu/packages/maths.scm
parent38dd27e866f2fc930afbd96223f0f6119d9ab1db (diff)
downloadguix-705af5403b3a8d7e942820bdff74195a1c3d9c89.tar.gz
gnu: superlu-dist: Update to 6.4.0.
* gnu/packages/maths.scm (superlu-dist): Update to 6.4.0
[source]: Use git-fetch, as tarballs are no longer published.
* gnu/packages/patches/superlu-dist-awpm-grid.patch: Remove all but the first
hunk; they are unnecessary.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 26625d5f50..7d841af8f5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2975,18 +2975,21 @@ also provides threshold-based ILU factorization preconditioners.")
 (define-public superlu-dist
   (package
     (name "superlu-dist")
-    (version "6.2.0")
+    (version "6.4.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://portal.nersc.gov/project/sparse/superlu/"
-                           "superlu_dist_" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/xiaoyeli/superlu_dist")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1ynmwqajc9sc3my2hssa5k9s58ggvizqv9rdss0j7w99pbh5mnvw"))
+        (base32 "0fa29yr72p4yq5ln4rgfsawmi5935n4qcr5niz6864bjladz4lql"))
        (modules '((guix build utils)))
        (snippet
         ;; Replace the non-free implementation of MC64 with a stub
         '(begin
+           (make-file-writable "SRC/mc64ad_dist.c")
            (call-with-output-file "SRC/mc64ad_dist.c"
              (lambda (port)
                (display "