summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-12-01 23:15:14 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-12-08 13:17:31 -0500
commit5537603fbf43525ab6a5ba9a4e911ae3ad9f712a (patch)
tree6bc4c2365e3a1fcf493d150cdc49d608ed511844 /gnu/packages/maths.scm
parentec60c3a58137ddb3c135999c3e7ccb90d51e3185 (diff)
downloadguix-5537603fbf43525ab6a5ba9a4e911ae3ad9f712a.tar.gz
gnu: Rename "octave" to "octave-cli".
* gnu/packages/maths.scm (octave): Rename to...
(octave-cli): ...this.
[name]: Change to "octave-cli".
(qtoctave): Inherit from octave-cli.
(flann)[inputs]: Adjust accordingly.
* gnu/packages/engineering.scm (qucs)[inputs]: Likewise.
(qucs-s)[inputs]: Likewise.
* gnu/packages/machine-learning.scm (shogun)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f88cede68a..e2f3e662c7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1413,9 +1413,9 @@ can solve two kinds of problems:
 
 ;; For a fully featured Octave, users are strongly recommended also to install
 ;; the following packages: less, ghostscript, gnuplot.
-(define-public octave
+(define-public octave-cli
   (package
-    (name "octave")
+    (name "octave-cli")
     (version "4.4.1")
     (source
      (origin
@@ -1498,20 +1498,20 @@ script files.")
     (license license:gpl3+)))
 
 (define-public qtoctave
-  (package (inherit octave)
+  (package (inherit octave-cli)
     (name "qtoctave")
     (source (origin
-              (inherit (package-source octave))))
+              (inherit (package-source octave-cli))))
     (inputs
      `(("qscintilla" ,qscintilla)
        ("qt" ,qtbase)
-       ,@(package-inputs octave)))
+       ,@(package-inputs octave-cli)))
     (native-inputs
      `(("qttools" , qttools) ;for lrelease
        ("texlive" ,texlive) ;for texi2dvi
-       ,@(package-native-inputs octave)))
+       ,@(package-native-inputs octave-cli)))
     (arguments
-     (substitute-keyword-arguments (package-arguments octave)
+     (substitute-keyword-arguments (package-arguments octave-cli)
        ((#:phases phases)
         `(modify-phases ,phases
            (add-before 'configure 'patch-qscintilla-library-name
@@ -3580,7 +3580,7 @@ in finite element programs.")
      `(("unzip" ,unzip)))
     (inputs
      `(("hdf5" ,hdf5)
-       ("octave" ,octave)
+       ("octave" ,octave-cli)
        ("python" ,python-2) ; print syntax
        ;; ("python2-numpy" ,python2-numpy) ; only required for the tests
        ("zlib" ,zlib)))