summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-09-11 09:38:39 +0100
committerLudovic Courtès <ludo@gnu.org>2018-09-11 17:46:29 +0200
commitaa82260bc098c3a2142230c6b787c39c00843ce1 (patch)
treef871f8d8be1bcb07497d16be694f41502d2d6c86 /gnu/packages/maths.scm
parentd2fe71b04d21d9f0374aa371e3229230e96dd97b (diff)
downloadguix-aa82260bc098c3a2142230c6b787c39c00843ce1.tar.gz
gnu: arpack-ng-openmpi: Fix build.
* gnu/packages/maths.scm (arpack-ng-openmpi)[arguments]: Add
'set-test-environment phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e1347e8fc..d1db75e658 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -508,7 +508,17 @@ large scale eigenvalue problems.")
     (arguments
      (substitute-keyword-arguments (package-arguments arpack-ng)
        ((#:configure-flags _ '())
-        ''("--enable-mpi"))))
+        ''("--enable-mpi"))
+       ((#:phases phases '%standard-phases)
+        `(modify-phases ,phases
+           (add-before 'check 'set-test-environment
+             (lambda _
+               ;; By default, running the test suite would fail because 'ssh'
+               ;; could not be found in $PATH.  Define this variable to
+               ;; placate Open MPI without adding a dependency on OpenSSH (the
+               ;; agent isn't used anyway.)
+               (setenv "OMPI_MCA_plm_rsh_agent" (which "cat"))
+               #t))))))
     (synopsis "Fortran subroutines for solving eigenvalue problems with MPI")))
 
 (define-public lapack