summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-25 15:37:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-25 15:50:57 +0300
commitc942e17c296c319704d0a78698a1987583250c68 (patch)
treecaa20081758cd87dca7ea87d176c9da7da7c2511 /gnu/packages/maths.scm
parentdc851004816ce70b5bb12fdf684efa544b7ef3a2 (diff)
downloadguix-c942e17c296c319704d0a78698a1987583250c68.tar.gz
gnu: qhull: Link binaries to shared library.
This drops the package size by nearly 60%.

* gnu/packages/maths.scm (qhull)[arguments]: Add configure-flag to link
binaries to shared library.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ee0a69bbd7..d0ca2f4647 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -247,6 +247,8 @@ programming languages.")
                (base32
                 "0zlbhg0lb6j60188c2xhcrvviskr079552icjldqhy1jhgmxghmm"))))
     (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags '("-DLINK_APPS_SHARED=ON")))
     (synopsis "Calculate convex hulls and related structures")
     (description
      "@code{Qhull} computes the convex hull, Delaunay triangulation, Voronoi