summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-01 22:49:33 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-01 23:30:15 +0100
commit725d35aa9aa12a843050379010a1591fb244c9b1 (patch)
tree1553b36c7206f7dba5b88fd2cbdcbd472d01a52e /gnu/packages/maths.scm
parentd64b78ef0c5a8850fdd1626034a5b152a0be9bcc (diff)
downloadguix-725d35aa9aa12a843050379010a1591fb244c9b1.tar.gz
gnu: scalapack: Update to 2.1.0.
* gnu/packages/maths.scm (scalapack): Update to 2.1.0.
[source]: Remove "scalapack-blacs-mpi-deprecations.patch" and add
"scalapack-gcc-10-compilation.patch".
[arguments]: Add 'skip-faulty-test' phase.
* gnu/packages/patches/scalapack-blacs-mpi-deprecations.patch: Remove.
* gnu/packages/patches/scalapack-gcc-10-compilation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 38fea4c43b..5d56f00095 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -977,7 +977,7 @@ provide LAPACK for someone who does not have access to a Fortran compiler.")
 (define-public scalapack
   (package
     (name "scalapack")
-    (version "2.0.2")
+    (version "2.1.0")
     (source
      (origin
        (method url-fetch)
@@ -985,8 +985,8 @@ provide LAPACK for someone who does not have access to a Fortran compiler.")
                            version ".tgz"))
        (sha256
         (base32
-         "0p1r61ss1fq0bs8ynnx7xq4wwsdvs32ljvwjnx6yxr8gd6pawx0c"))
-       (patches (search-patches "scalapack-blacs-mpi-deprecations.patch"))))
+         "19i0h9vdc3zsy58r6fy1vs2kz2l7amifkz0cf926j90xz1n23nb1"))
+       (patches (search-patches "scalapack-gcc-10-compilation.patch"))))
     (build-system cmake-build-system)
     (inputs
      `(("mpi" ,openmpi)
@@ -996,7 +996,15 @@ provide LAPACK for someone who does not have access to a Fortran compiler.")
      `(#:configure-flags `("-DBUILD_SHARED_LIBS:BOOL=YES")
        #:phases (modify-phases %standard-phases
                   (add-before 'check 'mpi-setup
-		    ,%openmpi-setup))))
+		    ,%openmpi-setup)
+                  (add-after 'unpack 'skip-faulty-test
+                    (lambda _
+                      ;; FIXME: Skip these two tests that fail to complete for
+                      ;; unknown reasons:
+                      ;; <https://github.com/Reference-ScaLAPACK/scalapack/issues/43>.
+                      (substitute* "TESTING/CMakeLists.txt"
+                        (("^add_test\\(x[sd]hseqr.*" all)
+                         (string-append "# " all "\n"))))))))
     (home-page "http://www.netlib.org/scalapack/")
     (synopsis "Library for scalable numerical linear algebra")
     (description