summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-06 15:52:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-07 09:10:44 +0300
commit67ce43c0d3664ea1f45b155e8e8857cf30e02c46 (patch)
tree382d77c879b6eb690e2ef70bc466bce5e42cfd55 /gnu/packages/maths.scm
parentf480f27c9c652c927e66d38a7183751303794711 (diff)
downloadguix-67ce43c0d3664ea1f45b155e8e8857cf30e02c46.tar.gz
gnu: openblas: Fix building on armhf-linux.
* gnu/packages/maths.scm (openblas)[arguments]: Add make-flag to set
target architecture.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 93b8ee2ad4..3d3d20d609 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3858,6 +3858,9 @@ parts of it.")
                   ;; On aarch64 force the generic 'armv8-a' target
                   ((string-prefix? "aarch64" system)
                    '("TARGET=ARMV8"))
+                  ;; Failed to detect CPU.
+                  ((string-prefix? "armhf" system)
+                   '("TARGET=ARMV7"))
                   (else '()))))
        ;; no configure script
        #:phases