summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-16 23:24:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-17 12:08:06 +0200
commit5c0b6d1b1db37a510367bf1e6441db32fda9568f (patch)
treede52b45f88711b658abf9e0aa2ec0f618b02e2ba /gnu/packages/maths.scm
parent3b42e2be921062fcc9f76e508e1284b9280c6809 (diff)
downloadguix-5c0b6d1b1db37a510367bf1e6441db32fda9568f.tar.gz
gnu: elemental: Don't use unstable tarball.
* gnu/packages/maths.scm (elemental)[source]: Download source using
git-fetch.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2e9472e3e3..9fb02b7385 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4074,13 +4074,14 @@ exclusion algorithms are typical examples of such systems.")
     (name "elemental")
     (version "0.87.7")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/elemental/Elemental/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/elemental/Elemental.git")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1nfp82w22pi8x8fg9sc37z8kf84dqi1dhxp8bbk7571y4aygvv3v"))))
+                "1687xpjjzig27y2pnqv7hv09smpijyfdpz7qjgmcxf4shfajlfkc"))))
     (build-system cmake-build-system)
     (home-page "http://libelemental.org")
     (native-inputs