summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-28 18:19:25 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-03 18:02:28 +0200
commite131f705dd0d605c5c4eddf183e8ff7d22b4c23b (patch)
treec8b3aa75c946beaa8c6ace3f880a4a9ebdf95b36 /gnu/packages/maths.scm
parente648957b7b99d140959311df6be46ed63338dd7f (diff)
downloadguix-e131f705dd0d605c5c4eddf183e8ff7d22b4c23b.tar.gz
gnu: dealii: Remove trailing booleans.
* gnu/packages/maths.scm (dealii)[snippet]: Remove trailing boolean (and
therefore the 'begin').
[native-inputs, inputs]: Reindent.
[arguments]<#:phases>: Remove trailing boolean.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0a92533d42..02da977954 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5191,22 +5191,20 @@ A unique design feature of Trilinos is its focus on packages.")
                                 "dealii-fix-sundials.patch"))
        (modules '((guix build utils)))
        (snippet
-        '(begin
-           ;; Remove bundled boost, muparser, TBB and UMFPACK.
-           (delete-file-recursively "bundled")
-           #t))))
+        ;; Remove bundled boost, muparser, TBB and UMFPACK.
+        '(delete-file-recursively "bundled"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (native-inputs
      ;; Required to build the documentation.
-      (list graphviz doxygen perl))
+     (list graphviz doxygen perl))
     (inputs
-      (list arpack-ng
-            openblas
-            gfortran
-            lapack
-            muparser
-            zlib))
+     (list arpack-ng
+           openblas
+           gfortran
+           lapack
+           muparser
+           zlib))
     (propagated-inputs
      ;; Some scripts are installed into share/deal.II/scripts that require
      ;; perl and python, but they are not executable (and some are missing the
@@ -5243,8 +5241,7 @@ A unique design feature of Trilinos is its focus on packages.")
              (let ((doc (string-append (assoc-ref outputs "doc")
                                        "/share/doc/" ,name "-" ,version)))
                (for-each delete-file (map (lambda (f) (string-append doc "/" f))
-                                          '("detailed.log" "summary.log"))))
-             #t)))))
+                                          '("detailed.log" "summary.log")))))))))
     (home-page "https://www.dealii.org/")
     (synopsis "Finite element library")
     (description