summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-12-18 13:36:55 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-20 15:28:14 +0100
commitef07f19b933c2e3e0e7219854d5acef157e8dda0 (patch)
treeb71902ee4cc72fb8de73ab047b728019b9cfe625 /gnu/packages/maths.scm
parent8159cd08d2e6cfe6f0974e52f8a37ba19a623f13 (diff)
downloadguix-ef07f19b933c2e3e0e7219854d5acef157e8dda0.tar.gz
gnu: dune-localfunctions: Update to 2.7.1.
* gnu/packages/maths.scm (dune-localfunctions): Update to 2.7.1.
  [arguments]: Parallelize build-tests phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8dc1c958e4..8b3a939941 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6587,7 +6587,7 @@ aggregation-based algebraic multigrid.")
 (define-public dune-localfunctions
   (package
     (name "dune-localfunctions")
-    (version "2.7.0")
+    (version "2.7.1")
     (source
      (origin
        (method url-fetch)
@@ -6595,7 +6595,7 @@ aggregation-based algebraic multigrid.")
                            version "/dune-localfunctions-" version ".tar.gz"))
        (sha256
         (base32
-         "1yih59h6vngii696bx1c2vil02lriij4kz0nc583mjn9kiaqxfqd"))))
+         "031i42anrhi0ngpvp42rdjbkic7v3008fwild9xg7flffwvnpshg"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
@@ -6613,8 +6613,12 @@ aggregation-based algebraic multigrid.")
                         ":"))
                #t)))
          (add-after 'build 'build-tests
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke "make" "build_tests" make-flags))))))
+           (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+             (apply invoke "make" "build_tests"
+                    `(,@(if parallel-build?
+                            `("-j" ,(number->string (parallel-job-count)))
+                            '())
+                      ,@make-flags)))))))
     (inputs
      (list dune-common
            dune-geometry