summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-12-05 20:06:00 +0000
committerLudovic Courtès <ludo@gnu.org>2018-12-10 00:28:11 +0100
commit72f95783f118a90e593e8c37922389ab199fdaeb (patch)
tree6b608ab7333a4abeee1fb3ec7a88c46d92c1da05 /gnu/packages/maths.scm
parent7e4bc215098f334bc2a11737f2665dd4992fc2da (diff)
downloadguix-72f95783f118a90e593e8c37922389ab199fdaeb.tar.gz
gnu: petsc-openmpi: Ensure compatibility of SCOTCH dependency.
* gnu/packages/maths.scm (petsc-openmpi)[inputs]: Replace pt-scotch
with pt-scotch32 in order to prevent 'incompatible pointer' warnings
being generated in the 'build' phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e088869682..96a1ecb043 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1775,7 +1775,7 @@ scientific applications modeled by partial differential equations.")
        ("mumps" ,mumps-openmpi)
        ("openmpi" ,openmpi)
        ("scalapack" ,scalapack)
-       ("scotch" ,pt-scotch)
+       ("scotch" ,pt-scotch32)
        ,@(package-inputs petsc)))
     (arguments
      (substitute-keyword-arguments (package-arguments petsc)