summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-07 00:02:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-08 05:29:29 +0200
commit0af12a1367b5ab8b94c3bdc99b1c1b3bba093610 (patch)
treeca8fded2da4c6f81c1f91fb6157ec3c0edff7968 /gnu/packages/maths.scm
parent2dc0a6cf368231b8f0a7cde7f9ceb68cad262f79 (diff)
downloadguix-0af12a1367b5ab8b94c3bdc99b1c1b3bba093610.tar.gz
gnu: maxflow: Correct version to 3.0.5.
This won't be picked up by ‘guix package -u’, but the code is identical
anyway.  By changing this now, fewer installations will fail to upgrade
at all if upstream ever release a new <3.4.

* gnu/packages/maths.scm (maxflow)[version]: Change to 3.0.5.
[source]: Use version tag instead of raw matching commit.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c1640fa02b..b4edc3f073 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1766,12 +1766,14 @@ ASCII text files using Gmsh's own scripting language.")
 (define-public maxflow
   (package
     (name "maxflow")
-    (version "3.04")
+    ;; Versioning is ambiguous: the git tag matching this commit is ‘3.0.5’,
+    ;; which matches CMakeLists.txt, but README.md and CHANGES say ‘3.04’.
+    (version "3.0.5")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/gerddie/maxflow.git")
-                    (commit "42401fa54823d16b9da47716f04e5d9ef1605875")))
+                    (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32