summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-14 19:26:34 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-14 19:27:14 +0100
commit166191b377e2e6117ab2a620e759724f7e446678 (patch)
tree65c9ef9451d6406bc786286aa43103e461b254cb /gnu/packages/maths.scm
parentb3345dc41abd81b048d9e712db235dfd404e1bfe (diff)
downloadguix-166191b377e2e6117ab2a620e759724f7e446678.tar.gz
gnu: Update packages to use 'non-copyleft' instead of 'bsd-style'.
* gnu/packages/avr.scm, gnu/packages/compression.scm,
  gnu/packages/curl.scm, gnu/packages/cyrus-sasl.scm,
  gnu/packages/databases.scm, gnu/packages/firmware.scm,
  gnu/packages/flex.scm, gnu/packages/fontutils.scm,
  gnu/packages/gd.scm, gnu/packages/ghostscript.scm,
  gnu/packages/gnunet.scm, gnu/packages/graphics.scm,
  gnu/packages/hugs.scm, gnu/packages/image.scm,
  gnu/packages/linux.scm, gnu/packages/mail.scm,
  gnu/packages/maths.scm, gnu/packages/mit-krb5.scm,
  gnu/packages/python.scm, gnu/packages/rdf.scm,
  gnu/packages/ssh.scm, gnu/packages/tcl.scm,
  gnu/packages/xdisorg.scm, gnu/packages/xiph.scm,
  gnu/packages/yasm.scm, gnu/packages/zip.scm: Use 'non-copyleft'
  instead of 'bsd-style'.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 52d5dd92a4..b6d3ed3680 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -238,7 +238,7 @@ be output in text, PostScript, PDF or HTML.")
     (description
      "ARPACK-NG is a collection of Fortran77 subroutines designed to solve
 large scale eigenvalue problems.")
-    (license (license:bsd-style "file://COPYING"
+    (license (license:non-copyleft "file://COPYING"
                                 "See COPYING in the distribution."))))
 
 (define-public lapack
@@ -271,7 +271,7 @@ large scale eigenvalue problems.")
     (description
      "LAPACK is a Fortran 90 library for solving the most commonly occurring
 problems in numerical linear algebra.")
-    (license (license:bsd-style "file://LICENSE"
+    (license (license:non-copyleft "file://LICENSE"
                                 "See LICENSE in the distribution."))))
 
 (define-public gnuplot
@@ -522,7 +522,7 @@ ASCII text files using Gmsh's own scripting language.")
     (description "PETSc, pronounced PET-see (the S is silent), is a suite of
 data structures and routines for the scalable (parallel) solution of
 scientific applications modeled by partial differential equations.")
-    (license (license:bsd-style
+    (license (license:non-copyleft
               "http://www.mcs.anl.gov/petsc/documentation/copyright.html"))))
 
 (define-public petsc-complex