summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-06 19:34:09 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-06 19:34:09 +0200
commit194c7f95f101afbec21b4662b1eb1e06f09fa293 (patch)
treee08d74eb9d1fe7c3e4d879a5efa06248517c5fab /gnu/packages/maths.scm
parenta1703aa76562143bcfdf9ac6efa914bbd9748626 (diff)
downloadguix-194c7f95f101afbec21b4662b1eb1e06f09fa293.tar.gz
gnu: Add FLANN.
* gnu/packages/maths.scm (flann): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2fc3ce19df..b56ca4057d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1930,3 +1930,39 @@ in finite element programs.")
            "-DMPI_Fortran_COMPILER=mpifort"
            ,@,cf))))
     (synopsis "Finite element library (with MPI support)")))
+
+(define-public flann
+  (package
+    (name "flann")
+    (version "1.8.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri
+          (string-append
+            "http://www.cs.ubc.ca/research/flann/uploads/FLANN/flann-"
+            version "-src.zip"))
+        (sha256
+          (base32
+            "022w8hph7bli5zbpnk3z1qh1c2sl5hm8fw2ccim651ynn0hr7fyz"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (inputs
+     `(("hdf5" ,hdf5)
+       ("octave" ,octave)
+       ("python" ,python-2) ; print syntax
+       ;; ("python2-numpy" ,python2-numpy) ; only required for the tests
+       ("zlib" ,zlib)))
+    (arguments
+     `(#:tests? #f)) ; The test data are downloaded from the Internet.
+    (home-page "http://www.cs.ubc.ca/research/flann/")
+    (synopsis "Library for approximate nearest neighbors computation")
+    (description "FLANN is a library for performing fast approximate
+nearest neighbor searches in high dimensional spaces.  It implements a
+collection of algorithms and a system for automatically choosing the best
+algorithm and optimum parameters depending on the dataset.
+
+FLANN is written in C++ and contains bindings for C, Octave and Python.")
+    (license (license:non-copyleft "file://COPYING"
+                                "See COPYING in the distribution."))))