summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
commit75710da66710cef1d32053cd8f350d13057d02a7 (patch)
treeabef6a326c741b1eb18db866b2f2bacee3e5fc51 /gnu/packages/maths.scm
parentab20c2cc33063ce783515d8ae7899ec7e2ca6f96 (diff)
parent610075f7c94c80b8321887b7ccf8bb1a7edd2b8e (diff)
downloadguix-75710da66710cef1d32053cd8f350d13057d02a7.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 11ffe4e781..45fda144be 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1926,3 +1926,39 @@ in finite element programs.")
            "-DMPI_Fortran_COMPILER=mpifort"
            ,@,cf))))
     (synopsis "Finite element library (with MPI support)")))
+
+(define-public flann
+  (package
+    (name "flann")
+    (version "1.8.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri
+          (string-append
+            "http://www.cs.ubc.ca/research/flann/uploads/FLANN/flann-"
+            version "-src.zip"))
+        (sha256
+          (base32
+            "022w8hph7bli5zbpnk3z1qh1c2sl5hm8fw2ccim651ynn0hr7fyz"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (inputs
+     `(("hdf5" ,hdf5)
+       ("octave" ,octave)
+       ("python" ,python-2) ; print syntax
+       ;; ("python2-numpy" ,python2-numpy) ; only required for the tests
+       ("zlib" ,zlib)))
+    (arguments
+     `(#:tests? #f)) ; The test data are downloaded from the Internet.
+    (home-page "http://www.cs.ubc.ca/research/flann/")
+    (synopsis "Library for approximate nearest neighbors computation")
+    (description "FLANN is a library for performing fast approximate
+nearest neighbor searches in high dimensional spaces.  It implements a
+collection of algorithms and a system for automatically choosing the best
+algorithm and optimum parameters depending on the dataset.
+
+FLANN is written in C++ and contains bindings for C, Octave and Python.")
+    (license (license:non-copyleft "file://COPYING"
+                                "See COPYING in the distribution."))))