summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:17:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:38 +0200
commit830971bf3aedcd389451d45e4ff8f7c6616d316f (patch)
tree1d781a737c4bbed7be9bed694fea3a0605e0b743 /gnu/packages/maths.scm
parent88efbab2d9ab1a6177ed3e792e60ed71ab6bc28c (diff)
downloadguix-830971bf3aedcd389451d45e4ff8f7c6616d316f.tar.gz
gnu: opencascade-oce: Don't use unstable tarball.
* gnu/packages/maths.scm (opencascade-oce)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 251684adad..0c0dc24b3f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1554,15 +1554,14 @@ script files.")
     (version "0.17.2")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append
-               "https://github.com/tpaviot/oce/archive/OCE-"
-               version
-               ".tar.gz"))
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/tpaviot/oce.git")
+              (commit (string-append "OCE-" version))))
+        (file-name (git-file-name name version))
         (patches (search-patches "opencascade-oce-glibc-2.26.patch"))
         (sha256
-          (base32
-            "0vpmnb0k5y2f7lpmwx9pg9yfq24zjvnsak5alzacncfm1hv9b6cd"))))
+          (base32 "0rg5wzkvfmzfl6v2amyryb8dnjad0nn9kyr607wy2gch6rciah69"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags