summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-08 23:04:00 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-08 23:04:00 +0100
commit95a4965f2df99d7dc7e2cd99330b3b27e0e5a947 (patch)
tree5f8d5c512940982097b048f060e1714525a90783 /gnu/packages/maths.scm
parentfe55ae488bcd9d57e83283f4c646ca5e302af756 (diff)
downloadguix-95a4965f2df99d7dc7e2cd99330b3b27e0e5a947.tar.gz
gnu: python-slepc4py: Update to 3.16.1.
This is a followup 5b4d1e57b6d4931f6ee2a50abf84222fe015d045.

* gnu/packages/maths.scm (slepc-openmpi)[inputs]: Move ARPACK-NG-OPENMPI to...
[propagated-inputs]: ... here.
(python-slepc4py): Update to 3.16.1.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3fecaa88c2..532d4249c9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3217,10 +3217,10 @@ arising after the discretization of partial differential equations.")
 	     ,%openmpi-setup)))))
     (inputs
      `(("mpi" ,openmpi)
-       ("arpack" ,arpack-ng-openmpi)
        ,@(alist-delete "arpack" (package-inputs slepc))))
     (propagated-inputs
      `(("petsc" ,petsc-openmpi)
+       ("arpack" ,arpack-ng-openmpi)
        ,@(alist-delete "petsc" (package-propagated-inputs slepc))))
     (synopsis "Scalable library for eigenproblems (with MPI support)")))
 
@@ -3235,14 +3235,14 @@ arising after the discretization of partial differential equations.")
 (define-public python-slepc4py
   (package
     (name "python-slepc4py")
-    (version "3.11.0")
+    (version "3.16.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "slepc4py" version))
         (sha256
           (base32
-            "1ksp08kxf4wg408b9nn39z3qfhy643j22d4rfbl30vzxk2rxh4lq"))))
+            "0fq997y73ymvcvdrxycp450pxwdgnqaw62gv9rwncfgsfplkvs9w"))))
     (build-system python-build-system)
     (arguments
      `(#:phases