summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-02-02 08:20:02 -0600
committerEric Bavier <bavier@member.fsf.org>2018-02-02 08:26:59 -0600
commitc684008992b0a0d2d8099dab48297fcf13b4a625 (patch)
treef92c61efe1fd1a133887a3974857e2eeada4079c /gnu/packages/maths.scm
parente01397b489dc1ec76fcbe33a26333ddcb92e20f8 (diff)
downloadguix-c684008992b0a0d2d8099dab48297fcf13b4a625.tar.gz
gnu: slepc: Apply invoke to configure flags.
Follow-up to 94a1eb96d32fcce97ee5d9440ecffe22f7555cd5

* gnu/packages/maths.scm (slepc)[arguments]: Use 'apply' since 'flags' is a
list of configure arguments.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 30a03a0fb6..dcb12199cb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1647,7 +1647,7 @@ scientific applications modeled by partial differential equations.")
               (format #t "configure flags: ~s~%" flags)
               (setenv "SLEPC_DIR" (getcwd))
               (setenv "PETSC_DIR" (assoc-ref inputs "petsc"))
-              (invoke "./configure" flags))))
+              (apply invoke "./configure" flags))))
          (add-after 'install 'delete-doc
           ;; TODO: SLEPc installs HTML documentation alongside headers in
           ;; $out/include.  We'd like to move them to share/doc, but delete