summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-17 19:16:53 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-17 19:47:15 +0200
commitf455d99dfaacd32411c224faa3020d594a7a24e9 (patch)
tree1ae95423549e47ba96d00f5012312b2c68c22eee /gnu/packages/maths.scm
parent7658904a34f0114ee5160be6ec4858fbec9dbe4c (diff)
downloadguix-f455d99dfaacd32411c224faa3020d594a7a24e9.tar.gz
gnu: edge-addition-planarity-suite: Move to the (gnu packages graph) module.
* gnu/packages/maths.scm (edge-addition-planarity-suite): Move from here...
* gnu/packages/maths.scm (edge-addition-planarity-suite): ...to here.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 1 insertions, 29 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b4e4067101..6d8fb9cec5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2016, 2017 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
@@ -5003,31 +5003,3 @@ command-line tools, and an Application Programming Interface (API).
 This package provides the static libraries required to run programs
 compiled against the nauty library.")
     (license license:asl2.0)))
-
-(define-public edge-addition-planarity-suite
-  (package
-    (name "edge-addition-planarity-suite")
-    (version "3.0.0.5")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-              (url (string-append "https://github.com/graph-algorithms/"
-                                  name))
-              (commit (string-append "Version_" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "01cm7ay1njkfsdnmnvh5zwc7wg7x189hq1vbfhh9p3ihrbnmqzh8"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)))
-    (synopsis "Embedding of planar graphs")
-    (description "The package provides a reference implementation of the
-linear time edge addition algorithm for embedding planar graphs and
-isolating planarity obstructions.")
-    (license license:bsd-3)
-    (home-page
-      "https://github.com/graph-algorithms/edge-addition-planarity-suite")))