summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-19 16:25:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-19 19:52:01 +0200
commit677bc34d5b75d4c9a8020f9d0f917c3ca2fb3dc6 (patch)
treeadd93700da018de01a67a18eea8747752f2a17b1 /gnu/packages/maths.scm
parent5857a0658a63cad0b32bc8a5a6770e2a57c0b500 (diff)
downloadguix-677bc34d5b75d4c9a8020f9d0f917c3ca2fb3dc6.tar.gz
gnu: Remove redundant cmake libdir configure flags.
* gnu/packages/bioinformatics.scm (imp)[arguments]: Remove
CMAKE_INSTALL_LIBDIR flag.
* gnu/packages/calendar.scm (libical): Same.
* gnu/packages/engineering.scm (kicad): Same.
* gnu/packages/games.scm (openrct2, mgba): Same.
* gnu/packages/gl.scm (virtualgl): Same.
* gnu/packages/image-processing.scm (mia): Same.
* gnu/packages/linux.scm (rdma-core): Same.
* gnu/packages/machine-learning.scm (dlib): Same.
* gnu/packages/maths.scm (lapack, superlu, z3): Same.
* gnu/packages/password-utils.scm (keepassxc): Same.
* gnu/packages/photo.scm (darktable): Same.
* gnu/packages/rdesktop.scm (freerdp): Same.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9e36b70cab..22d11302a5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -463,12 +463,6 @@ large scale eigenvalue problems.")
               ("python" ,python-2)))
     (arguments
      `(#:configure-flags (list
-                          ;; Install to PREFIX/lib (the default is
-                          ;; PREFIX/lib64).
-                          (string-append "-DCMAKE_INSTALL_LIBDIR="
-                                         (assoc-ref %outputs "out")
-                                         "/lib")
-
                           "-DBUILD_SHARED_LIBS:BOOL=YES"
                           "-DLAPACKE=ON"
 
@@ -1962,8 +1956,7 @@ void mc64ad_ (int *a, int *b, int *c, int *d, int *e, double *f, int *g,
     (arguments
      `(#:configure-flags '("-Denable_blaslib:BOOL=NO" ;do not use internal cblas
                            "-DTPL_BLAS_LIBRARIES=openblas"
-                           "-DBUILD_SHARED_LIBS:BOOL=YES"
-                           "-DCMAKE_INSTALL_LIBDIR=lib")))
+                           "-DBUILD_SHARED_LIBS:BOOL=YES")))
     (home-page "http://crd-legacy.lbl.gov/~xiaoye/SuperLU/")
     (synopsis "Supernodal direct solver for sparse linear systems")
     (description
@@ -3571,11 +3564,7 @@ as equations, scalars, vectors, and matrices.")
              "-DINSTALL_PYTHON_BINDINGS=true"
              (string-append "-DCMAKE_INSTALL_PYTHON_PKG_DIR="
                             %output
-                            "/lib/python2.7/site-packages")
-             (string-append "-DCMAKE_INSTALL_LIBDIR="
-                            %output
-                            "/lib"))
-
+                            "/lib/python2.7/site-packages"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'bootstrap