summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-08-15 22:56:59 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-08-17 10:47:52 -0400
commitb66741edc954f0a17f1ef567e8d612cac87c7b6a (patch)
tree243aa6209d251685fe84bbea17158e2fa4b2f460 /gnu/packages/maths.scm
parentb98eace814cfdde9e8632e0556761a910d6c8e6b (diff)
downloadguix-b66741edc954f0a17f1ef567e8d612cac87c7b6a.tar.gz
gnu: octave: Update to 4.4.1.
* gnu/packages/maths.scm (octave): Update to 4.4.1.
(qtoctave)[source]: Remove obsolete patch.
* gnu/packages/patches/qtoctave-qt-5.11-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 39668c7dbf..d4529e45b5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1350,12 +1350,12 @@ can solve two kinds of problems:
 @end enumerate\n")
     (license license:bsd-3)))
 
-;; For a fully featured Octave, users  are strongly recommended also to install
+;; For a fully featured Octave, users are strongly recommended also to install
 ;; the following packages: less, ghostscript, gnuplot.
 (define-public octave
   (package
     (name "octave")
-    (version "4.4.0")
+    (version "4.4.1")
     (source
      (origin
       (method url-fetch)
@@ -1363,7 +1363,7 @@ can solve two kinds of problems:
                           version ".tar.lz"))
       (sha256
        (base32
-        "0nm766737gbkq9wqry54a026k3dg7rb1065kngfpwgjz8b544xbp"))))
+        "0jsdgizlv02an2ppfjwk5qf209zpwi3317yb7jvlsjzxnir3lvhy"))))
     (build-system gnu-build-system)
     (inputs
      `(("lapack" ,lapack)
@@ -1433,10 +1433,7 @@ script files.")
   (package (inherit octave)
     (name "qtoctave")
     (source (origin
-              (inherit (package-source octave))
-              (patches (append (origin-patches (package-source octave))
-                               (search-patches
-                                "qtoctave-qt-5.11-fix.patch")))))
+              (inherit (package-source octave))))
     (inputs
      `(("qscintilla" ,qscintilla)
        ("qt" ,qtbase)