summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-17 21:45:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-17 22:26:30 +0200
commit885fe927e7648e6a7349acff163c0015bc3ab732 (patch)
tree1a622c89e457cb6d15e02824f562a885a86935f6 /gnu/packages/maths.scm
parent5686f5d7cdde6ba3149ef960149ff2ff323d49e2 (diff)
downloadguix-885fe927e7648e6a7349acff163c0015bc3ab732.tar.gz
gnu: glpk: Update to 5.0.
* gnu/packages/maths.scm (glpk): Update to 5.0.
(glpk-4.65): New variable.
* gnu/packages/algebra.scm (giac)[inputs]: Replace glpk with glpk-4.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c118e9e25c..794111afc4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -562,7 +562,7 @@ It can utilize SIMD instructions that are available on modern processors.")
 (define-public glpk
   (package
     (name "glpk")
-    (version "4.65")
+    (version "5.0")
     (source
      (origin
       (method url-fetch)
@@ -570,7 +570,7 @@ It can utilize SIMD instructions that are available on modern processors.")
                           version ".tar.gz"))
       (sha256
        (base32
-        "040sfaa9jclg2nqdh83w71sv9rc1sznpnfiripjdyr48cady50a2"))))
+        "05bgxidxj8d9xdp82niy7cy36w181cxq7p8vc3y2ixshpgp1642a"))))
     (build-system gnu-build-system)
     (inputs
      `(("gmp" ,gmp)))
@@ -586,6 +586,20 @@ translator for the language.  In addition to the C library, a stand-alone
 LP/MIP solver is included in the package.")
     (license license:gpl3+)))
 
+(define-public glpk-4
+  (package
+    (inherit glpk)
+    (name "glpk")
+    (version "4.65")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/glpk/glpk-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "040sfaa9jclg2nqdh83w71sv9rc1sznpnfiripjdyr48cady50a2"))))))
+
 (define-public 4ti2
   (package
     (name "4ti2")