summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-28 10:38:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-28 10:39:11 +0300
commit5b786db86c12550cfbb7564b0d3472aa6401d4ec (patch)
tree2461e1c3c395ba4124ce5dd7eb322ba80a42afbf /gnu/packages/maths.scm
parent2668e06efdebd3779361ab885d2a32b03a805540 (diff)
downloadguix-5b786db86c12550cfbb7564b0d3472aa6401d4ec.tar.gz
gnu: atlas: All phases return #t.
* gnu/packages/maths.scm (atlas)[arguments]: Ensure all custom phases
return #t.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f16e108656..5b31596041 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3369,13 +3369,15 @@ packages.")
              ;; Use `sh', not `/bin/sh'.
              (substitute* (find-files "." "Makefile|configure|SpewMakeInc\\.c")
                (("/bin/sh")
-                "sh"))))
+                "sh"))
+             #t))
          ;; Fix /bin/sh in generated make files.
          (add-after 'configure 'fix-/bin/sh-in-generated-files
            (lambda _
              (substitute* (find-files "." "^[Mm]ake\\.inc.*")
                (("/bin/sh")
-                "sh"))))
+                "sh"))
+             #t))
          ;; ATLAS configure program does not accepts the default flags
          ;; passed by the 'gnu-build-system'.
          (replace 'configure