summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-03 11:26:16 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-17 18:07:29 -0500
commitf5f642058a3b6bf3eda5eb714ad5fa1f0a2b1b20 (patch)
tree679153f71bd749d35f92a80a711b549f7ccb6066 /gnu/packages/maths.scm
parent9aa0a98ea0a93bf3db492833732cd4dc3d85debf (diff)
downloadguix-f5f642058a3b6bf3eda5eb714ad5fa1f0a2b1b20.tar.gz
gnu: wxmaxima: Update to 20.12.2.
* gnu/packages/maths.scm (wxmaxima): Update to 20.12.2.
[arguments]: Remove #:test-target and disable tests.  Remove 'pre-check
phase.
[native-inputs]: Remove xorg-server-for-tests.
[inputs]: Add libomp.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cb4640da41..eff1480e62 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -104,6 +104,7 @@
   #:use-module (gnu packages less)
   #:use-module (gnu packages lisp)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages logging)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages gnome)
@@ -3504,7 +3505,7 @@ point numbers.")
 (define-public wxmaxima
   (package
     (name "wxmaxima")
-    (version "20.06.6")
+    (version "20.12.2")
     (source
      (origin
        (method git-fetch)
@@ -3513,22 +3514,20 @@ point numbers.")
              (commit (string-append "Version-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "054f7n5kx75ng5j20rd5q27n9xxk03mrd7sbxyym1lsswzimqh4w"))))
+        (base32 "1rxnxk7yanb9ac5pxbii6k7gg3b09pbp9rmwvsvgpbrk17mg79r9"))))
     (build-system cmake-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("xorg-server" ,xorg-server-for-tests)))
-    ;; TODO: Add libomp for multithreading support.
-    ;; As of right now, enabling libomp causes the imageCells.wxm test to fail.
+     `(("gettext" ,gettext-minimal)))
     (inputs
-     `(("wxwidgets" ,wxwidgets)
+     `(("libomp" ,libomp)
+       ("wxwidgets" ,wxwidgets)
        ("maxima" ,maxima)
        ;; Runtime support.
        ("adwaita-icon-theme" ,adwaita-icon-theme)
        ("gtk+" ,gtk+)
        ("shared-mime-info" ,shared-mime-info)))
     (arguments
-     `(#:test-target "test"
+     `(#:tests? #f                      ; tests fail non-deterministically
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-doc-path
@@ -3539,13 +3538,6 @@ point numbers.")
              (substitute* "src/Dirstructure.cpp"
                (("/doc/wxmaxima-\\%s") "/doc/wxmaxima"))
              #t))
-         (add-before 'check 'pre-check
-           (lambda _
-             ;; Tests require a running X server.
-             (system "Xvfb :1 &")
-             (setenv "DISPLAY" ":1")
-             (setenv "HOME" (getcwd))
-             #t))
          (add-after 'install 'wrap-program
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (wrap-program (string-append (assoc-ref outputs "out")