summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-03 20:17:52 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-17 18:07:29 -0500
commit9aa0a98ea0a93bf3db492833732cd4dc3d85debf (patch)
tree9667b8f1ab8dd790163fad69a24f5fd8e4b99fe9 /gnu/packages/maths.scm
parent1b2c32dc919ec331bbd3219c586f46fe66e06346 (diff)
downloadguix-9aa0a98ea0a93bf3db492833732cd4dc3d85debf.tar.gz
gnu: gnuplot: Update to 5.4.1.
* gnu/packages/maths.scm (gnuplot): Update to 5.4.1.
[arguments]: Set GNUTERM in #:make-flags.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7866bcc6eb..cb4640da41 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -919,14 +919,14 @@ singular value problems.")
 (define-public gnuplot
   (package
     (name "gnuplot")
-    (version "5.2.7")
+    (version "5.4.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
                                   version "/gnuplot-"
                                   version ".tar.gz"))
        (sha256
-        (base32 "1vglp4la40f5dpj0zdj63zprrkyjgzy068p35bz5dqxjyczm1zlp"))))
+        (base32 "03jrqs5lvxmbbz2c4g17dn2hrxqwd3hfadk9q8wbkbkyas2h8sbb"))))
     (build-system gnu-build-system)
     (inputs `(("readline" ,readline)
               ("cairo" ,cairo)
@@ -938,7 +938,9 @@ singular value problems.")
        ("texlive" ,texlive-tiny)))
     (arguments `(#:configure-flags (list (string-append
                                           "--with-texdir=" %output
-                                          "/texmf-local/tex/latex/gnuplot"))))
+                                          "/texmf-local/tex/latex/gnuplot"))
+                 ;; Plot on a dumb terminal during tests.
+                 #:make-flags '("GNUTERM=dumb")))
     (home-page "http://www.gnuplot.info")
     (synopsis "Command-line driven graphing utility")
     (description "Gnuplot is a portable command-line driven graphing