summary refs log tree commit diff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-17 17:59:09 +0200
committerMarius Bakke <marius@gnu.org>2021-05-18 22:23:48 +0200
commitb52f635e411d37b9d0c5f5b26467ca47ebcdfcfe (patch)
treea6104287e59028bd64d811c42090d9d557eeaf47 /gnu/packages/maths.scm
parent6ee590eca8d67c21d678fb808bce9dc91542db14 (diff)
downloadguix-b52f635e411d37b9d0c5f5b26467ca47ebcdfcfe.tar.gz
gnu: hdf5: Fix invalid regex range.
* gnu/packages/maths.scm (hdf5-1.8)[arguments]: Use [a-zA-Z] instead of [a-Z]
as range in regular expression.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 33de445bea..6b3f5cf41c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1170,7 +1170,7 @@ incompatible with HDF5.")
              ;; libhdf5.so.  We truncate the hashes to avoid
              ;; unnecessary store references to those compilers:
              (substitute* "src/libhdf5.settings"
-              (("(/gnu/store/)([a-Z0-9]*)" all prefix hash)
+              (("(/gnu/store/)([a-zA-Z0-9]*)" all prefix hash)
                (string-append prefix (string-take hash 10) "..."))
               ;; Don't record the build-time kernel version to make the
               ;; settings file reproducible.