summary refs log tree commit diff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-28 22:32:40 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-04-01 15:14:28 +0300
commit536fa1bd236f958fdbdb518cd406d28493755538 (patch)
treed1957f4a9c68eef89168655e78b8f89fe3330811 /gnu/packages/matrix.scm
parenta45c110c9d77fe7969b992c3090f8b09aa461205 (diff)
downloadguix-536fa1bd236f958fdbdb518cd406d28493755538.tar.gz
gnu: Add python-matrix-client.
* gnu/packages/matrix.scm (python-matrix-client): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index a8d9d66ee7..5c2b194d07 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,6 +32,30 @@
   #:use-module (guix download)
   #:use-module (guix packages))
 
+(define-public python-matrix-client
+  (package
+    (name "python-matrix-client")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "matrix-client" version))
+       (sha256
+        (base32
+         "1mgjd0ymf9mvqjkvgx3xjhxap7rzdmpa21wfy0cxbw2xcswcrqyw"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-requests" ,python-requests)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-responses" ,python-responses)))
+    (home-page
+     "https://github.com/matrix-org/matrix-python-sdk")
+    (synopsis "Client-Server SDK for Matrix")
+    (description "This package provides client-server SDK for Matrix.")
+    (license license:asl2.0)))
+
 (define-public python-matrix-synapse-ldap3
   (package
     (name "python-matrix-synapse-ldap3")